Java 6 se runtime for mac

The WP Guru

By using our site, you acknowledge that you have read and understand our Cookie Policy , Privacy Policy , and our Terms of Service. Just installed a fresh version of Kepler 64bit "for Java Developers" on Yosemite, getting this error on first launch. Any thoughts on how to fix? Really do not want to downgrade my Java version! I just encountered this in another Eclipse-based app on Yosemite and figured out with help from the references below how to get the app running without installing the legacy Java SE 6 JRE.

Here are the steps in case it helps other devs get Eclipse working. Try to open the app from the command-line not sure if this is strictly necessary, but what I did.


  1. rebecca minkoff mini mac red?
  2. command option non mac keyboard.
  3. kindle software mac os x!
  4. adobe photoshop elements serial number mac;
  5. What Needs to Be Done?;
  6. free screen recorder mac 2013.

Go to System Preferences: Security Settings General and you should see the recent app next to a button "Open Anyway" -- click this button to open the app. However, I'm not sure that's strictly required. In any case, that wasn't sufficient -- I also had to change the JDK info. I was facing this trouble for hours.

How to install Java JDK on Mac OS X ( with JAVA_HOME )

I followed every suggestion I could find over numerous forums with no success. I resolved the issue by simply installing 1. I guess eclipse requires this.


  • black box with white text on my mac?
  • How to resolve Java SE 6 runtime message on Mac OSX 10.10 Yosemite & 10.11 El Capitan;
  • Upgrade to Sierra requires Java SE 6 to open FM | FileMaker Community.
  • Apparently this seems to coexist ok with the latest Java version which I also installed version 8 update 25 and version 8 shows up as the version I'm running when I verify from. I'm unclear on the security implications of this though, would have preferred another solution, if anyone finds a better solution than installing 6 please let me know. I made the problem go away by installing java version 1.

    About Jay Versluis

    My Mac crashed and after the restart I had the same issue. All Java 6 releases up to and including 6u45 have been moved to the Java Archive on the Oracle Technology Network, where they will remain available but not receive further updates. Oracle recommends that users migrate to the latest Java version in order to continue receiving public updates and security enhancements. If you have already tried the latest version and are facing issues running your Java Applets or applications, let us know the problems you encountered using the latest version.

    Updates for Java 6 are no longer available to the public. Oracle offers updates to Java 6 only for customers who have purchased Java support or have Oracle products that require Java 6. Oracle and Java.


    • Your Answer;
    • How to Install Java in OS X El Capitan!
    • yosemite - Where else can I download the legacy Java SE 6 runtime? - Ask Different.
    • Apple has posted notice that Mac OS X Chrome browser versions 42 and above. Starting with Chrome version 42, Chrome has disabled the standard way in which browsers support plugins.

      Resolved - Apple Java 6 for | MacRumors Forums

      More info. Mac OS X Apple's Java comes pre-installed with your Mac OS. Java is not pre-installed with Mac OS X versions If you have Java 7 or later versions, you will see a Java icon under System Preferences. Java versions 6 and below are listed in the Java Preferences. If you do not see a Java icon under System Preferences, Java 7 or later versions is not installed.

      If you are running a Java application in the browser, you will need to also check that Java is enabled in your browser.